Kemp Support, how can we help?

The latest application delivery knowledge and expertise at your fingertips.

100% disk usage /var/log/userlog

 

Information

 

Summary:

Disk usage for the  /var/log/userlog has maxed out at 100%

Environment:

Product: LoadMaster

Version: Any

Platform: Any

Application: Any

Question/Problem Description:

How to clear out the extended logs and free up disk space

Steps to Reproduce:  
Error Message:  
Defect Number:  
Enhancement Number:  
Cause:  
Resolution: There are a few ways to export/clear the Extended Logs and ensuring these logs don't fill up space on the LoadMaster:

  1. Use the API command. The command to clear extended logs is https://<LoadMasterIPAddress>/access/logging/clearextlogs. For full details on this command, and on our API in general, please click here.
  2. Clear them manually by selecting the connection logs from the list, then selecting "Clear" under Clear Extended Logs.
    • clear_extended_logs.png
  3. Prevent the logs from being recorded on the LoadMaster in the first place. To do this, navigate to System Configuration > Logging Options > Extended Log Files> check the box labeled Disable Local Extended ESP Logs. For this to work effectively, navigate to the Syslog Options tab and ensure you have at least one Syslog server configured set for the Informational syslog Level.
    • desable_local_logging.png

  • If the userlog fills up, it will simply stop logging any new ESP related logging. 
Workaround:  
Notes:  

Was this article helpful?
0 out of 1 found this helpful

Comments