Kemp Support, how can we help?

The latest application delivery knowledge and expertise at your fingertips.

Minimal time between health checks

 

Information

 

Summary: What is the lowest an administrator could set the Check Parameters to so there is the quickest interval before being notified a Real Server is failing?
Environment:

Product: LoadMaster

Version: Any

Platform: Any

Application: Any

Question/Problem Description:

How to set the health checks of a Real Server to respond as quickly as possible.

Steps to Reproduce:  
Error Message:  
Defect Number:  
Enhancement Number:  
Cause:

Within a Virtual Service, the health checks are used to monitor the availability of the Real Servers. If one of the servers does not respond to a health check within a defined time interval for a defined number of times, the Real Server is removed from the available Real Servers in the Virtual Service until it can be determined that this Real Server is back online.  Need to ensure the health checks are configured to make sure the least amount of time has passed for the updated status of a Real Server is reported.

Resolution:
  • The default settings are:
    • Interval (sec): 9
    • Timeout (sec): 4
    • Retry Count: 2
  • The Check Interval specifies the number of seconds that will pass between consecutive checks. The recommended value is 9 seconds. The minimum value for the Check Interval is Connect Timeout * Retry Count + 1, i.e. (4*2) + 1 = 9.
  • The Connect Timeout is the amount of time (in seconds) to wait for the Real Server to respond to the health check request. The recommended value is 4 seconds. If spurious timeouts are observed for health checks, this number may need to increase.

  • The Retry Count specifies the number of retry attempts the check will make before it determines that the server is not functioning.
  • The defaults are the lowest settings that can be configured for a health check.
  • health_check.png
Workaround:  
Notes:
  • In LoadMaster firmware version 7.2.52, the check Interval, Timeout, and Retry Count settings can be configured on each Virtual Service or SubVS. Previously, these were just global settings
  • For more information on health checks, click here.

Was this article helpful?
0 out of 0 found this helpful

Comments