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Failing health checks - Timeout waiting for connection

 

Information

 

Summary:

This article will cover what the Timeout waiting for connection log message indicates

Environment:

Product: LoadMaster

Version: Any

Platform: Any

Application: Any TCP-based application

Question/Problem Description:

Why are we seeing health checks fail?

Steps to Reproduce:  
Error Message: Removing RS <RealServerIP>:<RealServerPort> from VS <VirtualServiceIP>:<VirtualServicePort>(<VirtualServiceName>) - Timeout waiting for connection
Defect Number:  
Enhancement Number:  
Cause:

This happens when a TCP-based health check is used, but the TCP connection from the LoadMaster to the real server fails.

This means one of three scenarios is happening:

  1. The SYN packet from the LoadMaster is not received by the server,
  2. The SYN packet is getting dropped at the server, or
  3. The SYN/ACK packet is not making it back from the server.
Resolution: Environmental investigation is needed.
Workaround:

If the environment has been investigated and it's been confirmed that everything is working as expected, Rules & Checking > Check Parameters can be increased globally, or this can be done by navigating to Virtual Services > View/Modify Services > modify the desired Virtual Service > if applicable, expand the SubVS tab and modify the desired SubVS > Real Servers. This should only be done if it's been confirmed via a packet capture that the LoadMaster is receiving the SYN/ACK packet back from the server, but a proper amount of time hasn't been allowed for health checking to pass.

To confirm this behavior, a packet capture should be taken from the LoadMaster, as outlined here: https://support.kemptechnologies.com/hc/en-us/articles/6370901430157-Troubleshooting-Connectivity-to-the-Virtual-Service

Notes:  

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