Kemp Support, how can we help?

The latest application delivery knowledge and expertise at your fingertips.

Let's Encrypt + SubVSs

 

Information

 

Summary:

When Sub Virtual Services are needed for Let's Encrypt.

Environment:

Product: LoadMaster

Version: Any

Platform: Any

Application: Any

Question/Problem Description:

When are Sub Virtual Services needed for Let's Encrypt?

Steps to Reproduce:  
Error Message:  
Defect Number:  
Enhancement Number:  
Cause:  
Resolution:

Sub Virtual Services (SubVSs) are needed when initially requesting a new certificate.

The SubVSs are not needed for renewal.

Since SubVSs are not needed after the initial request and generation of a certificate, the SubVSs can be deleted if desired. Once deleted the real servers must be re-added.

To delete SubVSs follow the below steps:

1. Go to Virtual Services > View/Modify Services.

2. Click Modify on the relevant Virtual Service.

3. Expand the SubVSs section.

4. Delete any existing SubVSs.

You will then see the option to Add New real servers.

 

Workaround:  
Notes:

https://support.kemptechnologies.com/hc/en-us/articles/17482608955661-Let-s-Encrypt-Set-Up

https://docs.progress.com/bundle/loadmaster-feature-description-lets-encrypt-ga/page/Introduction.html


Was this article helpful?
1 out of 1 found this helpful

Comments