Kemp Support, how can we help?

The latest application delivery knowledge and expertise at your fingertips.

ADFS not working on new LoadMaster

 

Information

 

Summary:

ADFS 2019 not working on new LM-X15, but same configuration works on LM-3600.

Environment:

Product: LoadMaster

Version: 7.2.48

Platform: Any

Application: ADFS

Question/Problem Description:

ADFS 2019 not working on new LM-X15, but same configuration works on LM-3600.

Steps to Reproduce:  
Error Message:  
Defect Number:  
Enhancement Number:  
Cause: ADFS 2019 is not completing the backend SSL handshake using the new OpenSSL version on the LoadMaster.
Resolution: The older SSL library must be enabled by navigating to Certificates & Security > SSL Options > OpenSSL Version > Change from Use current SSL library + TLS 1.3 to Use older SSL library - no TLS 1.3.
Workaround:  
Notes: https://support.kemptechnologies.com/hc/en-us/articles/6263363906573-AD-FS-v3

Comments