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Listening port cannot write to file

 

Information

 

Summary:

In system messages appeared several errors listening port cannot write to nfcapd file.

Environment:

Product: FOS

Version: Any

Platform: Any

Question/Problem Description:

After deleting the profile, source or channel or after importing the configuration from the original appliance an inconsistent can occure and internal processes are trying to write to a directory that is no longer defined.

In case of corrupted filesystem the /data/ partition is locked to read only due to data protection.

Steps to Reproduce:  
Error Message:

Listening port X cannot write to file /data/nfsen/profiles-data/live/(source)/(date)/nfcapd.X

Defect Number:  
Enhancement Number:  
Cause:

Internal processes are trying to write to a directory that is no longer defined.

Corrupted filesystem.

Resolution:

Check by command:

dmesg.sh

first if there are errors regarding the XFS filesystem.

If no XFS errors are visible, restart the built-in collector (Configuration Center -> FMC Configuration -> Basic Settings -> Built-in collector state -> stop/start) or use the command:

sudo /bin/systemctl restart nfsen

Wait 10 minutes, if the errors appear again with a new timestamp in the GUI. If it does and it is distributed architecture deployment, it is necessary to restart the distributed architecture backend with the command:

sudo /bin/systemctl restart dist_managerd

After that, delete the error message from the system messages. If the error occurs again or you see XFS errors in the dmesg log, please contact support and provide us with appliance logs.

Workaround:  
Notes:  

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