Listening port cannot write to file
Information
Summary: |
In system messages appeared several errors listening port cannot write to nfcapd file. |
Environment: |
Product: FOS Version: Any Platform: Any |
Question/Problem Description: |
After deleting the profile, source or channel or after importing the configuration from the original appliance an inconsistent can occure and internal processes are trying to write to a directory that is no longer defined. In case of corrupted filesystem the /data/ partition is locked to read only due to data protection. |
Steps to Reproduce: | |
Error Message: |
Listening port X cannot write to file /data/nfsen/profiles-data/live/(source)/(date)/nfcapd.X |
Defect Number: | |
Enhancement Number: | |
Cause: |
Internal processes are trying to write to a directory that is no longer defined. Corrupted filesystem. |
Resolution: |
Check by command dmesg.sh first if there are errors regarding xfs. Restart the built in collector (Configuration Center -> FMC Configuration -> Basic Settings -> Built-in collector state -> stop/start) or use command systemctl restart nfsen For DA solutions use command: systemctl restart dist_managerd Delete error from system messages. If the error occurs again or you will see xfs errors in dmesg, please contact support and provide us appliance logs. |
Workaround: | |
Notes: |