Exchange 2016 with ESP

0

Hi,

I have setup a TEST.INTRANET domain where I have 1 Free Loadmaster to publish Exchange services, 2 MBX behind. They're all on the same subnet.

Everything is working fine (L7) with the template "Exchange 2016 HTTPS Reencrypted", OWA, MAPI over HTTPS.

But when I enable ESP it doesn't work anymore... I have setup the LDAP server, the SSO and the SubVS with the help of the guide. Is there something missing or misconfigured ?

 

The OWA SubVS (which is acutally working when ESP is disabled)


Pre-authorization Excluded Directories (I'm not sure of this) : /owa/886deb2f-9c6e-490a-a746-1d7aed4d1392@test.intranet*

 In the Extended Log, when I try to https://mail.test.intranet/ I have this error : 

Blocked access to invalid directory '/' from 172.16.0.116:51215 to 172.16.107.104:443 

when I try to https://mail.test.intranet/OWA I have this error : 

Blocked access to invalid host 'mail.test.intranet' from 172.16.0.116:51229 to 172.16.107.104:443

Any suggestions ?

 

3 comments

Avatar
0
bgleeson

Initial thoughts would be that requests are not hitting the SubVS above but instead are hitting a different SubVs.

Blocked access to invalid directory '/' from 172.16.0.116:51215 to 172.16.107.104:443

         

You may need to add another Rule to match "/" URL This can be done with the following:

Rule Type: Content Matching

Match String: /^\/$/

 

This should result in the traffic going through the OWA SubVS.

 

For the Second Issue, I would make sure the Content Rule for OWA has the setting "Ignore Case" set under the Content Rule definition.

 

Barry

Avatar
0
Jérôme DUMET

Hi,

I deleted everything to start from scratch... xD

But ESP don't work... There are alreday the good rules with the template :





Avatar
0
Stephan Mey

Hey,

 

you have to set Server Authentication Method to "Basic Authentication" on the bottom (ESP Options) in your 3rd screenshot :-)

 

Regards

Stephan