Configure 2 NIC on different VLAN

0

Hello! Everybody

I have Two VLM (HA) with one NIC configure in the Same VLAN for both. Example 1st VLM 192.168.10.10 ; 2nd VLM 192.168.10.11. I need to configure the Second additional NIC of both VLM to a different VLAN. I need to know what is the best practice to doing this and then add new Virtual Service for this VLAN. Example: 172.17.50.x

I try assigned the Gateway for second additional NIC and the option Use for Default Gateway is disable (Grey out). I resolve It configure HA Shared IP Address. Thanks Tony Vaughan. When I try to Ping IP: 172.17.50.10 timeout because the GW isn't configure yet.

Existing VLAN (Different Segment):
New VLAN to Configure (Different Segment):

Is possible to configure different NIC (eth0 - eth1) of VLM to Different VLAN and Gateway? How to do this?

Please Help!

Thanks and Regards!

8 comments

Avatar
0
Tony Vaughan

Hello,

to change the gateway to another interface,
you first need to enable the option "Enable Alternate GW support"
you can find this under
System Configuration -> Miscellaneous Options -> Network Options


from the screenshot you posted you already have this enabled but you are missing the Shared IP address,
this is needed when the units are in HA mode

if you are looking to change the gateway for a VS only instead of globally
you can use the option "Use Default Route Only" in the menu
System Configuration -> Miscellaneous Options -> Network Options
after this you would add the default gateway to the VS under the Advanced Properties

 

Avatar
1
Macho RD

Hello, Tony Vaughan

Thanks for you answer but I have some issue. I Put the option "Use for Default Gateway" on Network Interface 1 and the VLM they stopped functioning which causes a downtime in the service. Because the description for this option says: Enable the ability to move the default gateway to a different interface. I don't wan to move the gateway to Interface 1 because this interface belongs to another gateway.

What I actually need is to place a Virtual Service (VIP) of another subnet with another gateway. Is it possible to do this?

Other question what is exactly "Use Default Route Only" if I select this option my working Virtual Service on Interface 0 stop working? The Actually Virtual Service take the Global Default Gateway to work.

Example of one Virtual Service:

Thanks and Regards!

Avatar
0
support

have you tried setting "default gateway" (Advanced Properties) in the virtual service? I guess your (global) default GW is on 192.168.10.0/24. if you want to define a default gateway for a service in 172.17.50.0/24 you have to set the default GW in in this virtual service (Advanced Properties -> Default Gateway).

Avatar
0
Macho RD

Hello Support

I not tried the setting Default Gateway for a Virtual Service Yet. Is correct about my Global Default GW is on 192.168.10.0/24. Currently revert changes to the network interface 1 (clean) due to the inconvenience caused in the service. 

Can you tell me how to just configure a virtual service that is on another subnet 172.17.50.0/24? 

Thanks and Regards!

Avatar
0
support

You can just add a VS with an ip address from 172.17.50.0/24 subnet. you just need a interface in this subnet. after that configure the default gw for this VS as described above.

 

PS: my account name is support (because of my email address) but i am not from kemp support :-)...

Avatar
0
Macho RD

OK about you name. PS: Can you tell me your name?

Other question about interface 1 in the subnet [172.17.50.0/24]. How this IP 172.17.50.10/24 | HA Shared IP 172.17.50.11 | HA Partner IP 172.17.50.12. Will respond if the gateway is not configured? Remember the Interface 0 have the default gateway configured for different subnet [192.168.10.0/24].

Thanks and Regards!

Avatar
0
Macho RD

Hello!

Can anybody have a solution or answer for this post?

Thanks and Regards!

Avatar
0
mallain

Hello EveryBody,

 

I've got the same problem of Macho RD. When i two different VS on two different interface network. Even if i configure the default gateway for the VSS. Traffic will always go to the global default gateway of my KEMP FreeLoadmaster.

 

Is there somenone that can explain me/us how to configure kemp load master so that flow will use the right default gateway?

 

Thanks  and regards