2 Virtual service in different network default gateway not working

0

Hello EveryBody,

 

I've got a problem with my kemp Topology.

I've got one kemp FreeLoadmaster on azure with 2 network card. On each interface i configure different Virtual Services.

Even if i configure the default gateway for the virtual service. Traffic will always go to the global default gateway of my KEMP FreeLoadmaster.

 Is there somenone that can explai,  how to configure kemp load master so that flow will use the right default gateway for each Virtual service?

 

Thanks  and regards

4 comments

Avatar
0
Tony Vaughan

Hello,

can you make sure that the option "user default route only" is enabled,
this can be found under system configuration -> miscellaneous options  -> network options

this will force the LoadMaster to use the virtual service gateway instead of the globally default gateway

Avatar
0
mallain

Hello Tony,

thanks for your reply.

As you can see on this screenshot, "use default route only" is enabled.

 

The global default Gateway is 192.168.12.6 and is affected to my eth0 interface.

On a VS configure on 192.168.14.5 connected to my eth3 interface ( see picture), i configure the default Gateway on 192.168.14.1

But when i test client connection to this VIP (192.168.14.5) and check network packet with Microsoft message analyzer on the destination real server , i always view source ip as 192.168.12.6 ( global default network on eth0) !! it's very strange.

i don't understand why...

Regards 

Mickaël

 

Avatar
0
Tony Vaughan

Can you take a TCP trace from the LoadMaster,

if you do not see traffic connecting to the VS gateway,
I would recommend opening a support case so my colleagues are get some more details 

TCP trace can be taken from the menu
Logging options -> system configuration -> debug options : TCP dump
please note that the LoadMaster will only capture the first 10000 packets by default,

please filter on the VS gateway address just to make sure we don't miss the traffic being captured

 

 

Avatar
0
mallain

Hello Tony, 

thanks for your reply. I've solve my problem , it was a lack of understanding about network. 

I did not select the option "server originating request " correctly.

So the traffic seemed to come from the default gateway, instead of the source network of the real servers.

 In reality, the default gateway functionality at the VS level was operational.

Regards