Outlook Out of Office and Kemp Transparency

0

Hi,

 

I hope someone can help.

I have a Test Exchange 2010 setup that consists of:

free Kemp virtual appliance (V7.1.32a-88)

Exchange 2010 SP3 servers

Windows 7, Outlook 2007 PC

Exchange servers, Kemp and the PC are all on a different subnets.

Exchange servers and Virtual servers on the kemp are on the same subnet.  So this is a one arm configuration as I understand it.

 

I have a virtual server on the Kemp setup for HTTPS traffic, this consists of subVS for eas, ecp, ews and owa.  Transparency is not enabled on the SUBVs's, but is enabled on the top level Virtual Service (This is greyed out and I cannot change it).

I have a dns entry called "mail" that points to the above virtual service on the kemp.

On the PC,  I see the following:

- When I try and open the Out of Office assistant it errors with "Your out of office settings cannot be displayed because the server is currently unavailable".

- Trying to download the offline address book just hangs on "connecting to exchange".

- When creating a new appointment and clicking on the scheduling assistant, the suggested times shows the message "Suggestions cannot be provided because free/busy data could not be retrieved".

If I create a new virtual service with no SUBVs's and point the "mail" dns entry to it, I can replicate the errors above by enabling transparency.  If I change the Virtual Service to Force Layer7 so I can untick transparency everything works.

So it looks like transparency is my problem but I am not sure how to fix it.  It seems that when I create a new Virtual service, select Force Layer7, untick transparency but then add a SUBVS even if I untick transparency it gets selected on the main virtual service and creates the problem.

Note I have the HTTPS virtual service with SUBVS's configured the same on the live KEMP appliances and I don't get the same issue.  Again the Exchange servers, Kemp and clients are on different subnets, but the Exchange servers and Kemp Virtual services are on the same subnet (One arm configuration).

Note that in my test domain and live domain the Exchange servers default gateway's are not pointing to the kemp.

Can anyone please help.

Regards

Matthew Ridley

3 comments

Avatar
0
Mark Deegan

Hello Matthew,

the transparency being greyed out on the parent VS denotes that the VS is a parent with sub VS's/ The sub VS's actually handle traffic based on their settings. The parent only does SSL offloading and http content matching. i would recommend using the exchange template from http://kemptechnologies.com/loadMaster-documentation/

regards

Mark

Avatar
0
matthew.ridley

Hi Mark,

Thank you for the reply.  I have found out that the problem was.

On the main virtual service when originally setting it up I had enter a port of 80.  All the SUBVS's were set to 443 and the Exchange server were configured to use port 443.

So it was my mistake and it was obvious, but it has taken me a few days to spot it!

 

Avatar
0
Mark Deegan

No Problem Matthew.