Outlook Clients Popup AutoDiscover redirect warning

0

Hello,

we have installed an Loadmaster HA and 3 MS Exchange 2016 Server. The Loadmaster is configured via Exchange 2016 HTTPS Reencrypted Template and all virtual Services works fine. Only if I try to config Outlook Clients via Autodiscover, I get a Redirect Warning Message.

If I disable the "Exchange 2016 HTTPS Reencrypted - HTTP Redirect" Virtual Service, no Redirect Warning Message appears. But now, if an User types the http-Adress in the browser to connect OWA, the browser shows "Connection Failed".

How can I modify the Virtual Services, that all works correct.

Thanks
   Thomas

5 comments

Avatar
0
matthias.koller

I have the same issue:

- one Namespace (internal/external is the same)

- autodiscover is correctly configured

- Outlook 2010 - 2016 popup is displayed if a new profile will be configured with autodiscover

 "Allow this Website to configure user@domain.com server setting?...Your account was redirected to this Website for settings. You should only allow settings from sources you know and trust."

 

This:

https://support.microsoft.com/en-us/kb/2480582

or any ideas?

Avatar
1
Mark Deegan

Hello all,

this is usually because the RPC service is defaulting to try over HTTP instead of HTTPS on the exchange servers. You can set the RPC to be over https and this warning will disappear or a workaround on the KEMP is to change the port 80 redirect from "302 Found" to "301 Moved Permanently" under advanced properties on the redirect VIP.

Regards

Mark

Avatar
0
gross

Did this fix the problem for you guys? Just installed 2016 and starting to get the same popup message in Outlook? I did make the change on the LB and we are still getting the popup.

Avatar
0
Josh Winters

Mark's fix worked for me. Exchange 2013 with Outlook 2016 client.

Avatar
0
drew

Can the "301 Moved Permanently" be added to the Template file? Seems like it would save a lot of grief for everyone. The 301 worked for me as well.