A security scan of our network has highlighted that our Kemp HLBs have a vulnerability.
Version source : SSH-2.0-OpenSSH_6.7
Installed version : 6.7
Fixed version : 7.0
Are there any plans to upgrade to OpenSSH v7 very soon ?
This is the output from the scan:
CRITICAL OpenSSH < 7.0 Multiple Vulnerabilities
According to its banner, the version of OpenSSH running on the remote host is prior to 7.0. It is, therefore, affected by the following vulnerabilities :
A flaw exists in the kbdint_next_device() function in file auth2-chall.c that allows the circumvention of MaxAuthTries during keyboard-interactive authentication.
An attacker can exploit this issue to force the same authentication method to be tried thousands of times in a single pass by using a crafted keyboard-interactive 'devices' string, thus allowing a brute-force attack or causing a denial of service. (CVE-2015-5600)
A security bypass vulnerability exists in sshd related to PAM support. An authenticated, remote attacker can exploit this to impact the pre-authentication process, allowing the possible execution of arbitrary code. Note that this issue only affects Portable OpenSSH.
A flaw exists in sshd due to setting insecure world-writable permissions for TTYs. A local attacker can exploit this, by injecting crafted terminal escape sequences, to execute commands for logged-in users.
A use-after-free error exists in sshd related to PAM support. A remote attacker can exploit this to impact the pre-authentication process, allowing the possible execution of arbitrary code. Note that this issue only affects Portable OpenSSH. (OSVDB 126033)
Upgrade to OpenSSH 7.0 or later.