Virtual services remote access not working

0

Hello,

 

I have installed my freeloadbalancer but i am running on an issue. The virtual service for my webservers (port 80) that i have created is accessible in it's subnetwork (10.0.43.0/34) but if i want to access to it from a remote network (10.0.47.0/24), it won't work. But the real web servers can be contacted on port 80 tough. 

I have reinstalled many times my freeloadbalancer but i can't seem to find a way through this problem.

1 comment

Avatar
0
Mark Deegan

Hello,

It might be because of routing. I Would first check if the service is transparent. if so disable transparency then enable "Subnet originating requests" under standard options, then under "advanced properties" of the VIP there is an option for default gateway. please make sure that the correct default gateway for the network that the VIP is on, is entered here. You will then need to go to "System Configuration -> Miscellaneous Options -> network Options" and enable the setting "Use Default route Only". this will ensure that the traffic returns on the path of origin.

regards

Mark