super http and check paramaters

0

We don't seem to be getting an even load across our servers.  We are using super http round robin with tcp checks  should we switch to https checks for better balancing?

 

thanks

 

5 comments

Avatar
0
Mark Deegan

Hello Tony,

 

This may be because some connections are lasting longer than others. to get better balancing I would try changing from round robin to least connection. You do not need to change the real server check parameters.

 

regards

 

Mark

Avatar
0
Tony Roth

thanks, was contemplating least connection can't really come up with a downside.

 

Avatar
0
Tony Roth

I should have added that the load balancing issue is really at the cpu level in this case, not connections.  We'll get 1 or 2 servers out of 4 that are 100% while the others are running 0-10%.  We've contemplated using the lmagent do you think that help? 

 

thanks again.

tr

 

 

Avatar
0
Mark Deegan

Hello Tony,

indeed the adaptive scheduler may work for you  in this instance. to do this there are 2 parts. first you have to setup the agent on the real servers and decide on levels at which your server will not accept more connections and second to enable it on the Load master. please see the article below for specifics. Can i ask which version of server are you using as the setup on 2008 server is different to the setup on 2012 server.

https://support.kemptechnologies.com/hc/en-us/articles/203126529-Install-Adaptive-Agent

regards

Mark

Avatar
0
Tony Roth

windows 2008 r2, Vers:7.1.34.1.12802.RELEASE (AZURE)  we'd previously had the lmagent configured but it seems like users login and sit so then the cpu is doing nothing so it keeps allowing users on to a given server then all of a sudden users start using the application, at that point there is nothing for the load balancer to do its to late, right?

Since the application is used by group of users within a given facility I think there is a potential for this type of activity pattern.  Just a guess at this point.