IKEv2 DHCP and missing routes


Ok so I have a really weird issue and I am hoping that someone has a solution.

Currently I am running the following

2 KEMP 2600's in an HA configuration

2 Windows 2012 R2 servers configured with remote access VPN (NOT DA)

1 DC with DHCP installed with one scope defined for the VPN network. Scope option 121 is defined for Classless Static Routes (so vpn clients can find there way into the network)

And several system / network configurations that allow everything to talk correctly.


Here is the scenario...

I have two L4 services defined (at this time they are wild card so all ports are allowed) one for TCP and one for UDP both using the same VIP. The services are pointing to two real servers which are the Remote access servers. I have disabled traffic to one of the real servers so that all traffic will go to just a single server (for testing). Take any windows  system to act as a client in this case I am using a windows 10 Ent. system. I create a vpn connection using the built in tools in windows however under advanced settings I change the VPN type to SSTP and then establish my connection. In this case everything works great and I get my DHCP address and all the Static Routes that I need and I can access resources on the corp network. However if I change the VPN type to IKEv2 and create a connection everything works as expected with one exception and that is I do not get any of the Static Routes and I am unable to access the corp network.

Now if I run those same two tests again but remove the KEMP's and connect directly to the server both test succeed and I get my static routes every time as expected. Is there a configuration that I should be using on the KEMP service definitions that will allow routes to be assigned when connecting using IKEv2?



1 comment

Darren Morrissey

Hello Sorry for the late reply. This issue would more than likely require a remote session. Can you please create a support ticket with a copy of your backup configuration. System Admin > Backup/Restore