Poor performance for Exchange RPC

0

Hi,

i have implemented the free loadmaster with the exchange 2010 templates.

All function are okay, but i have very poor throuput for rpc (Outlook Anywher): 170Kb/s.

Waht can i do?

regards

Robert

7 comments

Avatar
0
Mark Deegan

Hello Robert,

The RPC is probably using HTTP as opposed to HTTPS for RPC. Please configure your port 80 redirect to be "301" instead of "302" under advanced properties and enable NTLM auth on the exchange servers for the MAPI.

regards

Mark

Avatar
0
r.kobben

Hello Mark,

Thanks for your quick response!

But I mean RPC-over-HTTP (Outlook Anywhere)!

Regards

Robert

 

Avatar
0
Mark Deegan

Hi Robert,

The RPC over HTTP is considered MAPI and EWS in exchange. A pass though 443 service here would fix the issue I am thinking.

regards

Mark

Avatar
0
r.kobben

Hi Mark,

can you explain me whats the best way to do this? Sorry, i am new with KEMP!

Thank you!

regards

Robert

Avatar
0
benzpatrik

***Update 26.02.2017 19:31*****

Problem is independent of the loadmaster type (free vs commercial)

***************************

 

Hi Robert

I have the same problem as you. I tested it with a Windows IIS Server and a Synology Filestation application.
I did the tests over Port 80 and 443, so that I can exclude a Problem with SSL connections.

Both system have the same poor throughput of less than 200 kb/s.
I will do another tests with the Kemp trial virtual Loadmaster, perhaps it's just a problem of the free Loadmaster in the actual build.

regards

Patrik

Avatar
0
benzpatrik
Avatar
0
steven

I see the same poor performance (around 200 KB/s) on our lab's free LM as well (version 7.2.37.1.14531.RELEASE VMware). With or without SSL accelleration enabled.

There is another topic on this issue:  https://support.kemptechnologies.com/hc/en-us/community/posts/115000399863-Slow-troughput-virtual-kemp-VLM-200-on-Hyper-V-2012R2

I'm under the impression its a bug.