New setup - Sharepoint VS status down



No doubt a newby question...


Using the templates for Sharepoint 2013 HTTPS Offloaded.

Have added a VS and a Real Server as per the SharePoint deployment guide.

Once I add the URL of "/" the status stays down. If I change the check method something else - say ICMP - the status is up.

Am I missing something here ?


The other part of the doco I cannot find in the WebUI is where I add the "**" in the HTTP redirector as it says in the notes, but that is a secondary issue.

All help appreciated.






Tony Vaughan

Morning Ian,

just to recap the steps I would use for troubleshooting health check issues,

i would recommend starting at the lowest level and working your way up

set the health check to ping,
if this passes - the LM is able to find the RS
if this fails - ping is being blocked or there is a routing issue, (depending on the scenario if the real server is local or non-local to the LoadMaster)

set the health check to TCP connection,
if this passes - the LM is able to find the RS and the port is opened on the server
if this fails - port is being blocked, ACL is blocking traffic from the LoadMaster's IP or the service isn't running on the server for example IIS/Apache

if possible set the health check to HTTP,
if this passes - the LM is able to find the RS and the port is opened on the server and the service is running correctly
if this fails - check the log message on the LoadMaster to confirm the error e.g. server responded with a 404 or 403

Set the health check to HTTPS,
if this passes - the LM is able to find the RS and the port is opened on the server and the service is running correctly
if this fails - unfortunately the logs doesn't include the server response error message, I would get a TCP dump to confirm that the three-way handshake and then the SSL handshake is successful

back to your question
if this is on HTTP can you check the LM logs and see if there is any server response error code,
since this is for SharePoint you may be missing the HTTP 1.1 host name (see screenshot)

for your second question,
can you highlight the section where you talk about the HTTP redirector?



Thank you for the response.

The diagnostics provided will be helpful to others on the same path.

Yes, it was the lack of HTTP 1.1 and host name as I just followed the guide and it does not mention this.

Regarding the HTTP redirector I see this in the configuration:

The Deployment guide says this:

The far right column is titled "Comment" but I don't see where I should be added a HTTP Redirector.

Regards and Thanks,


Tony Vaughan

Hi Ian,

Glad you got the health check working,

for the issue with the redirect,
on the HTTPS virtual service you should see the option in the screenshot below,
this will only be visible if you do not have a HTTP virtual service on the same IP address

using this option will create a HTTP port 80 VS with a redirect

if you already have a service on the port 80 HTTP virtual service
can you check that it is set as a redirect and that it has no real servers applied to it

under Advanced Options -> Not available redirection handling
set the error code to "302 found"
and the redirect URL to "https://%h%s"

any clients connecting on HTTP will now be redirected to HTTPS

one last thing to note is that you may to be aware of is this

you may want to change the redirect url from "https://%h%s" to "https://<yourdomain>%s"


Still had issues with the redirector that was created from the templates. What I ended up doing was deleting the redirector VS, then modifying the HTTPS VS to "add a Port 80 Redirector VS" which creates a fresh (separate) redirector VS. This worked fine. I then modified the new redirector VS to give it a description and change the redirect URL to replace the %h with the FQDN as per Tony's advice.

The Sharepoint side all works now. I will post a new topic for my OOS questions !

Thanks Tony, hope this thread is of use to others.