Redirect all Http to Https

0

Hello Guys, I'm trying  redirect Http to Https , but does not work.  what is wrong? 

 

4 comments

Avatar
0
Bill DeCastro

Hi,

I see you don't have any real servers applied, which can be a contributor to the 80 > 443 redirection issue.

Other than this, the most likely cause of the disconnect would be a firewall blocking HTTP/port 80 traffic.

Has this been checked?

Avatar
0
jsantos

I have two real servers and If I open http://www.xpto.com does not forward to  https://www.xpto.com

Avatar
0
Bill DeCastro

If you have two servers applied to the HTTP VS, then these should be removed. The redirection will only take place if the servers all fail health checks or are not present.

Avatar
0
Justin Federico

@jsantos

Usually, depending on your version, you would have the option to create an HTTP redirect from the HTTPS Virtual Service. This would create a new port 80 virtual service that would be configured to handle the redirection. If you already have port 80 Virtual Service on the same IP as your HTTPS VS then you will not see this option on the HTTPS VS.

Which service is displayed in the screenshot? HTTP or HTTPS?

You can try to delete the HTTP (80) VS and see if you have the "Add a Port 80 Redirector VS" option under Advanced Properties of the HTTPS (443) VS. Selecting this option will create the redirect VS for you.