content-length header required

0

Hi All

I migrated our single sign on service from some old Brocade ADX load balancers to our Kemp VLM-3000, all seems to be working correctly however one of our application teams has reported that an API call (to the sso service) is failing as it now seems to require the content-length header in the request, this wasn't previously required prior to the migration. We have SSL acceleration enabled with reencrypt.

Does anyone have any idea what could be causing this?

Many Thanks

Dave

1 comment

Avatar
0
Nick Smylie

Hi @kempadmin

Is the LoadMaster throwing the error?  Can you go to:

System config > misc options > L7 config > Enable 'Allow Empty POSTs'.

This setting allows a POST to not have a content length header in the request.  By default this setting is off.