HTTP VS with Apache as Real Server not working

0

Hi there,

I try to get a simple HTTP VS with an Apache Server in the backend up and running.

I tried it with and without the Apache template. But when I try to open the Website, I get just a looooong time nothing and then the browser gives the error "page loadingerror" "error: connection interrupted".

I tried every option in the VS, nothing helps. I see no entry in the Logs, maybe I am looking in the wrong directions.

If I call the apache directly, I get the page I requested.

The Apache itself is nearly out of the box, so no akward settings done here.

Any suggestions?

Martin

5 comments

Avatar
0
Brian Morich

Hi Martin,

Does the Apache server pass healthchecks on the LoadMaster? That being is it displaying as up/green from the View/Modify Services menu.

 

As far as suggestions go, I'd make sure the option of "Transparency" stays disabled, also if the service is marked as red/down you could lower the healthchecks to TCP connection only.

 

Let me know if you'd like me to open up a support ticket for you, so that we could work on this more easily.

 

 

Avatar
0
SecondLevel-Support

Hi Brian,

the healthcheck is working, setting it to TCP connection only does not change a thing.

Also transparency off or on does not change a thing.

Is there another way to debug the request? Do I have to wireshark the request?

Martin

Avatar
0
Brian Morich

Hi Martin,

Running a TCP dump can certainly help investigate this issue, that can be done under System Configuration -> Logging Options -> System Log Files > Debug Options -> TCP dump

We can filter on the ip address of the real server or virtual service.

if we go to the options field under TCP dump we can filter on both by typing host 192.x.x.x or host 10.x.x.x

These should be the addresses of the virtual service and corresponding real server

You can also enable extended debugging under System Configuration -> Logging Options -> System Log Files > Debug Options -> Enable Extended L7 Debug

This will then need to be enabled on the virtual service, after that debug logs for this service will populate under your system message files.

Avatar
0
SecondLevel-Support

Found the solution, the Kemp has two NICs (nic0 = IPa and nic1 = IPb). We had to set the Default Gateway in the VS under Advanced Properties. Without the default gateway in the VS, the request came from nic0 with IPa, but the answer came over NIC1 with IPb. The service did not like the asynchronous routing.

Post can be closed.

Martin

Avatar
0
Brian Morich

Hi Martin,

Glad to hear its working.

That is correct, If a VIP is created on a network where the LoadMaster's global default gateway does not reside, the gateway for that particular network must be added to the VIP under "Advanced Properties" otherwise the traffic will try to leave out of the interface where the global gateway resides, thus causing an asymmetric route.