Cannot use WUI addresses as a VIP

0

Hi everyone,

 

when I try to add a VS on the public IP and port 443 I get following error message.

 

Our WUI has a different IP than the VS I want to create, only the port is the same :(443)

I used following steps as workaround:

1) Change Port of WUI to e.g. :8443

2) Reconnect to WUi

3) Create VS

4) Change WUI back to Port 443

5)  Be happy :)

Is it possible that there is an error in the validation of the IP address or port?

 

LoadMaster Version 7.2.50.0.18765.RELEASE

 

Thanks in advance,

Moritz

3 comments

Avatar
0
Brian Morich

Hi Moritz,

Do you have this IP address residing anywhere on the LoadMaster?

This error really should only be occurring if the LoadMaster thinks this address is being used for web access or resided on eth0 or eth1

Avatar
0
moritz.hofmann

Hi Brian,

 

following example:

eth0 (DMZ): 1.2.3.4

eth1 (internal DMZ): 192.168.0.100

 

WUI and API are only accessable over eth1.

Then I tried to create the VS with IP 1.2.3.4 and Port 443 and got the error: Cannot use WUI address as a VIP.

For my understanding this should be possible and I already have an older Kemp Load Master(7.2.46.0.17392.RELEAS) in my lab environment where this has worked.

Avatar
0
Brian Morich

Hi Mortiz,

Thank you for clarifying, I tested this out myself and experienced the same behavior.

I believe this is expected as the IP/port combination for the eth0 address (1.2.3.4) and the WUI port (443) still exists on the LoadMaster even though it is not currently being used for WUI access.

If we were to go to the console of the LoadMaster and navigate to Local Administration -> Web Address

We can see that the eth0 IP and WUI port can be selected. in the event that the WUI interface had to be changed from the console (perhaps If WUI access is lost) we can change it from the console without the need for WUI access.